Error Installing custom app

We are trying to install custom app on Freshdesk portal, but we are not able to install the app. We are getting below error message. We could not able to identify the issue, since it is working fine in the local environment. Could you please help resolve the issue as one of customer is waiting for this app.

Hey @Gokul_Chakkaravarthi

Could you please share the app details (app_id & version_id)?

1 Like


possible, please share with us the HAR logs and screenshot of the console error that you get while installing the custom app?



Hi here below have added Both the id’s of the app

App id: 12098
Version id : Live Version 45.0

Please find HAR file attached (1.2 MB)

Any help on this . Customer is waiting for the update

Hi @Gokul_Chakkaravarthi

Thanks for reverting back with the required details. It seems the onAppInstallCallback seems to get timed out while the app setup event is triggered. Kindly try verifying it once. Please reach out to us if you need any further assistance.


Hi ,
We have checked out in local environment the onAppInstallCallback event is working fine. But on portal it shows error as we mentioned above and so that we cannot able to install app on portal . Could you please help resolve this timeout issue ?


Could you please check whether this post helps?

Also, It seems the app uses a third-party library like Axios HTTP client for making requests. We strongly recommend using the request method to avail of the benefits and security. Please let us know the use case behind using the third-party library.

Hi @Anand_Chandran ,

We have used the request method but we do have a same issue as on above screenshot . So we have tried using Axios HTTP to make an API we do have same issue while Installing app . Could you please help us to resolve this issue ?

Hello @Gokul_Chakkaravarthi

Can you confirm the app properly invokes renderData as captured in this post @Anand_Chandran shared?

Can you let us know what dependencies you are using for this app? Often some of the dependencies are too bulky and consumer a lot of your execution time to load. Have you considered removing any of your unused dependencies or trimming the list of dependencies?

Thirdly, if there are API requests your app makes in the onAppInstallCallback, do any of these take longer than a few seconds each?

Hi @satwik

We have cross verified that we have using renderData in onAppInstallCallback as mentioned in the documentation . Also we have been using axios instead of request to check But still issues cannot be resolved. Dependencies we have installed “request”: “2.72.0”, “base-64”: “0.1.0”,“axios”:“0.27.2”. Please let me know if you need more details.


As per our analysis, we suspect the request made on the appInstallCallback took more time to complete the request transaction. Could you please manually verify that the request made to the third-party API doesn’t take much time?

If the issue still persists, Block a time in our calendar to talk with one of the developer relations engineers to get help over a call.

cc: @Raviraj


Hi @Raviraj ,

Thanks for your time on the call today, changing it to request API and adding the static IP parameter solved the issue. Now we can able to install and uninstall the app without any issues.


Thanks for the confirmation, @Gokul_Chakkaravarthi!

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.