Issues with Custom apps publishing in Freshcaller

Hey guys,

I am unable to publish custom apps in any of the Freshcaller accounts that I have access to. I tried re-uploading the apps with different names, tried them in different accounts, but nothing works.

In the Dev Portal, the app’s status says “Development” instead of “Internally published” and I received emails suggesting the failure to upload the app as below:

Could someone please help regarding this issue? This is impacting an app delivery due to the inability to test the app as a custom app.


Hi @Anand_Ganesan ,

Are you sure that assets folder is under the root directory?

If not, Can you please move the assets folder under the root directory.

Hi @ManiDeepak_Vandrangi

I moved the style and JS files from assets to my iparams HTML file and now I’m able to publish custom apps.
But I noticed a different issue this time with being able to install the custom app.

Attaching the screenshot below for your reference:

Could someone help me regarding this issue?


Hi @Anand_Ganesan,
Good Day! Thank you for reaching Freshworks Marketplace.

you can follow the below URL for an assets folder setup inside config directory.
"You can add external assets, such as .css and .js, in the ‘config/assets’ folder to render the Custom Installation page."

For the error which you got is there any console error?
can you please ensure passing the correct values in postConfig and validate function?

and I have another suggestion, if your Custom Iparmas contains only those fields such as
Account URL, API Key and Email Address and not doing any operations other than validation in the verify credentials button then I would suggest use Iparams.json with Domain, API and email fields

Kindly let me know if you are having any other questions.

Santhosh B
Freshworks Marketplace.

1 Like

Hi @Santhosh,

Thank you for your suggestions, the issue with the app install was related to calling renderData function in time, and I was able to fix that issue.


A post was split to a new topic: Calling Server Method from Custom Install page results in timeout

Hello @Anand_Ganesan. Since the original issue with respect to custom apps being published has been resolved, do you mind if we continue the follow-up troubleshooting in another topic? We would want to ensure that other developers are not misled by seeing an app publication topic open for a long time, when there is currently no platform issue with publishing apps.