Cannot test Freshdesk app

I’m followed the Quick Start Quick Start ( and I’m not able to test the App locally.

The Test App guidance Quick Start ( don’t work.
The Google Chrome just don’t try to open the local site.

Can someone provide a more detailed step by step guide in how to create and test a Freshdesk App?

Thank you!

1 Like

Hi @murilocurti,

Welcome to our developer community!

Our documentation link that you have attached is the best step-by-step procedure to get started with the app development on our v2 platform.

If you have successfully installed FDK and created the fist app, after the app has been with fdk create, by following the rest of the steps carefully to see the app loading within your Freshdesk account is the way to get it work.

Could you share the errors or screens or which step are you stuck at?

1 Like

Hi! I will describe here the steps and the results that I’m using, ok?

  1. Go to an empty temp folder: cd C:\temp\fresh

  2. Check node version: node --version

  3. Check fdk version: fdk version
    Installed: 6.9.4
    Already Up to Date…!

  4. Create an app: fdk create
    ?Choose a Product: (Use arrow keys)
    > freshdesk
    ** freshservice**
    ** freshsales**
    ** freshchat**
    ** freshconnect**
    ** freshcaller**
    ** freshteam**

  5. Choose freshdesk
    ? Choose a template: (Use arrow keys)
    > your_first_app
    ** your_first_serverless_app**
    ** sample_crm_app**
    ** advanced_iparams_app**

  6. Choose your_first_app:
    ├── app
    │ ├── index.html
    │ ├── scripts
    │ │ └── app.js
    │ └── styles
    │ ├── images
    │ │ └── icon.svg
    │ └── style.css
    ├── config
    │ └── iparams.json
    ├── manifest.json

5 directories, 7 files

  1. Check Google Chrome version: chrome://settings/help
    Google Chrome is up to date
    Version 87.0.4280.88 (Official Build) (64-bit)

  2. Run the app: fdk run
    (node:4664) Warning: Accessing non-existent property ‘VERSION’ of module exports inside circular dependency
    (Use node --trace-warnings ... to show where the warning was created)
    Starting local testing server at http://*:10001/
    **Append ‘dev=true’ to your Freshdesk account URL to start testing **
    e.g. There is no helpdesk here!
    Quit the server with Control-C.

  3. Log in the Freshdesk account: https://{subdomain}

  4. Append the ?dev=true to the URL: https://{subdomain}

    No message about loading scripts from unauthenticated resources.
    No app icon on the sidebar.

Please see the Chrome console log generated when loading that URL (7.8 KB) .**

That is the point we stopped and we don’t know what to do.

Hope that information can help.

Thank you in advance @Raviraj !


1 Like

@murilocurti Were you able to do these steps as well? This will let the browser open the app running with the server on localhost HTTP server.

  1. Navigate to Settings -> Advanced -> Privacy and security -> Site settings -> Insecure content .
  2. In the Allow section, click Add and enter the Freshdesk account URL. Example URL:
1 Like

Also, looks like #2 -> you are using node version of 14.15.0 ! To avoid any inconsistencies, we would recommend you to use 10.16 or above for now.

1 Like

We rebuilt the hole environment with the node version 10.16 and it still not working and Chrome doesn’t try to access the insecure content.


@murilocurti I couldn’t quite understand what’s wrong on your end with the given information.

Could you please schedule a slot in our calendar to troubleshoot and fix the issue? It would also be a good feedback for us resolve if there’s any information missing in the Quick start instructions.