Can't install fdk with npm (ENOENT ... node_modules/.staging)

Node version : 12.22.7
npm version : 6.14.15

Hi, I’m trying to install the FDK on my Linux Sub System and can’t find a way to properly do it.

My installation creates tons of warnings and “depricated” errors.
I installed NVM, Node… but : $npm install -g
does not work properly.

And my fdk command is not found.

I’ve tried a previous solution found on one of Fresh’s forum : $npm install -g --allow-root --unsafe-perm=true
but it doesn’t work either.

I’ll link my error log : (127.0 KB)

Thanks for your help.

Hi @lobose,

Welcome to our community!

Could you check if the same FDK installation command from the documentation works with sudo prefix to give it admin privileges if the folder has been restricted for your current user profile?

If it works with Sudo, you might have changed the Node 12’s or FDK’s folder’s permissions, I guess.
To do a clean install, NVM and Node can be uninstalled and directories cleaned up to install them according to the documentation steps. This can be a final possible solution as well.

I already tried as super user that doesn’t change the problem, i’ve also resetted my hole ubuntu environment and it didn’t work either.

@lobose You are trying to install Freshworks CLI (FDK) version 6.x on Node version 12. FDK version from 7.x only supports the Node version 12.
Could you try a fresh install of FDK with FDK version 7? This would be installed if the exact steps from the documentation followed to install the latest stable version of Freshworks CLI (FDK).

@lobose hi, when you say Linux sub-system, do you mean you are running this in WSL (Windows Subsystem for Linux)? If yes, can you let us know:

  • WSL version — 1 or 2
  • Ubuntu OS version
  • Windows version & build

I tried the installation on an Ubuntu 20.04 running in Windows 11 using wsl2. Installed perfectly. The issue here is possibly related to your specific Windows Subsystem for Linux (WSL).

Log shows the error is related to syscall rename which seem to be reported time and again in the WSL repo, e.g., issue #2097, issue #2836. Can you check those issues for some insights?

All of them are warnings as a result of unsupported dependencies down the chain. But it is not the source of the error.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.