Cant test app locally

I’m developing an app for Freshworks CRM but am unable to test it locally. When I append ?dev=true to a contact, it says “FDK serving local app” but the contact_entity_menu is blank.

I have previously been able to get around this issue by adding &tab=123456789 to the url, but it recently stopped working and says “You’re trying to access a hidden section under Contact details. Talk to your admin.”.

I haven’t intentionally touched Freshcaller and debug mode shows this, not sure if it’s relevant:

(iframe.js) Received local app render request for product freshcaller which is not present in the list of products in the app manifest. Falling back to freshworks_crm.

Any ideas what the issue could be? Help would be greatly appreciated.

Node: 14.20.0
FDK: 8.6.6
Platform Version: 2.2

Hi @Nathan_Oh

Welcome to the community :partying_face:

Good Day!

Is the placeholder of your app is contact details page?
Can you please share the manifest.json file and error log from the console if any?

Please check the below one @Nathan_Oh

/crm/sales/contacts/70060868473?tab=entity-card-detail - Please check if query has been already available in the URL ( ?tab=entity-card-detail ). If the query is available then we need to add dev=true like below.




@Nathan_Oh - Can you try sharing a screenshot of this page?

1 Like

Yes, the placeholder is in the contact details page.

Here is my manifest.json:

  "platform-version": "2.2",
  "product": {
    "freshworks_crm": {
      "location": {
        "contact_entity_menu": {
          "url": "index.html",
          "icon": "icon.svg"
        "full_page_app": {
          "url": "index.html",
          "icon": "icon.svg"
  "engines": {
    "node": "14.20.0",
    "fdk": "8.6.6"

Here are the console errors when running:

I’m not 100% sure what you mean by query already available, but I’m guessing you’re asking if the url I’m testing on already has a query parameter. This is what my url looks like when trying to test: /crm/sales/contacts/86031460693?dev=true, so there’s no query parameter before ?dev=true.

Sure. It’s the same as when trying dev=true without setting the tab, but it redirects to the default url (/crm/sales/contacts/86031460693) while still not showing anything in the contact details page. The message I was referring to was from a toast:

@Nathan_Oh - I tried running the app locally.

Here’s what my URL looks like

My role on the account is Admin.

Do you happen to test this in production (as a custom app)? Could it be possible that the role that your account’s access level doesn’t allow you to open contact details page?

1 Like

Sorry, I was out the past couple days for Thanksgiving.

The URL you sent lines up with what I’m trying. I also checked my role, and the account I’m using is an Account Admin. I’m testing the app in a live CRM to emulate a real use-case scenario, and I looked in the role permissions area in admin settings and I have access to everything.

At this point I really have no clue what the issue might be. I’m going to try my setup on a new computer to see if I can isolate the issue to an environment bug.

I’ll get back with the results, thank you for the help so far.

Also while I have you, quick side question:

With a recent update contacts open in a side panel first, and then redirect to the contact page upon clicking a “See all details” button. My custom apps that usually show in the contact details section don’t show in the entity menu of this initial contact preview. Is it possible to make them appear here?

No luck. Same issue on a new setup. However, I figured out how to get my old workaround working again – instead of setting ?dev=true&tab=123456789, I set ?dev=true&tab=123456789__123456789 and now the app shows. This solution should suffice for my needs, so this issue can be closed now.

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.