Could not able to install FDK on Windows

As FDK is needed for custom app creation for Freshchat, I was tried to install it through command prompt on Windows Server 2016, it fails and thrown issues. below are the error logs from command prompt.

Windows server 2016 Error logs.txt (7.6 KB)

Later, I was tried to install the FDK on other Windows 10 system through WSL, it fails and throws issues, below is the screenshot of it.

Windows 10 WSL|690x289

Please help me out on this to proceed further.

Hello @RCreditcorp,

Can you please execute this command and try installing FDK in case of Windows OS:
npm install --global --production windows-build-tools

Also, if you are installing FDK 8, can you please try with a lower version of node, say Node v14?


1 Like

Hi Aravind,

I was tried to run the below command, but terminal is not responding further. please check the below screenshot for reference.
npm install --global --production windows-build-tools


Thank you.

Hey @RCreditcorp,

  1. From your attached image, it seems that node 14 is not present. Could you please try to set up node 14 first by using this command: nvm install 14?

  2. After the above step, can you try executing the same command mentioned before: npm install --global --production windows-build-tools

  3. Irrespective of step 2, I see that there are errors when setting up the sqlite3 package from your first screenshot. So can we try this command: npm cache clean sqlite3?

  4. After all the above steps, please try installing FDK v8.


Hi Aravind,

Currently NVM version is 14, and trying to run the command, but the terminal is not responding since 2 hours. Attached the screenshot for reference.



Hey @RCreditcorp,

Can you please cancel that process and try npm cache clean sqlite3. After this, please try to install FDK v8.


Also, as an alternative for that command, can you please try: npm install --global --production windows-build-tools@4.0.0?

Hi Aravind,

I ran the below commands in the order,

  1. nvm install 14
  2. npm cache clean sqlite3
  3. node --version, currently it is v16.13.2
  4. nvm alias default 14, to default node to v14, but it is not set.

Check below screenshot for reference


Later, I was tried to run the below suggested command, and followed by fdk installation command

  1. npm install --global --production windows-build-tools@4.0.0
  2. npm install -g

Still I could not install FDK, please check below attachment for reference.

Terminal error logs.txt (8.7 KB)


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.