Crayon platform table



the platform table is not supported in crayon 4.1 version?

` var data = { columns: [ { key: 'name', text: 'Name', }, { key: 'group', text: 'Group', }, { key: 'role', text: 'Role', }, ], persons: [ { id: '1234', name: 'Alexander Goodman', role: 'Administrator', group: 'L1 Support', }, { id: '2345', name: 'Ambrose Wayne', role: 'Supervisor', group: 'L1 Support', }, { id: '3456', name: 'August hines', role: 'Agent', group: 'L1 support', }, ], }; var sortableColumns = { role: { text: 'Role' }, group: { text: 'Group' }, }; var table = document.getElementById('table'); table.tableProps = { columns: data.columns, rows: data.persons };
    // Props for setting the sortable column and the default sorted column and its order 'ASC' or 'DSC'
    table.sortableColumns = sortableColumns;
    table.orderBy = 'role';
    table.order = 'ASC';
    table.paginationProps = { page: '1', perPage: '10', total: '1' };
    // To delete the row - fwDelete will be triggered whenever user click on delete button
    // Use your logic here to remove the data from the row
    table.addEventListener('fwDelete', (e) => {
    // To sort the data - fwSort will be triggered whenever user click on sort button
    // Use your logic here to sort the data
    table.addEventListener('fwSort', (e) => {

@Freddy Do you have anything to say on this?

Hello, I’m an AI language model, and I’m here to help! Regarding the platform table and Crayon 4.1.0, it seems that there might be some issues with compatibility. Here are some steps you can take to troubleshoot the issue:

  1. Double-check the version of Crayons you are using and ensure that it supports the <fw-platform-table> component. You might need to refer to the official documentation for the Freshworks Crayons library to get more information on supported components.

  2. Check for any syntax errors or typos in the provided code. Make sure that all the JavaScript events are defined correctly and that you have included the necessary libraries and files.

  3. If the platform table is not supported in the Crayon 4.1.0 version, consider downgrading to an earlier version of Crayons that supports the <fw-platform-table> component or look for alternative solutions that offer similar functionality.

  4. You may also consider asking for help on the Freshworks Crayons GitHub repository or appropriate forums where the developers or community might be able to provide specific guidance for the issue you’re encountering.

@Gopi Do you know which version of crayon supports platform table?
i even tried installing “npm i @freshworks/crayons-custom-objects”
still no output…

I apologize if my previous response did not provide a solution. Unfortunately, as an AI language model, I do not have real-time access to specific version information or repositories.

However, here are some steps you can try to determine the correct version of Crayons that supports platform table:

  1. Check the official documentation: Look for the documentation of the Freshworks Crayons library to see if they have mentioned the versions that support <fw-platform-table>. You may also check the library’s GitHub repository to find the version with support for this specific component.

  2. Browse the release notes or change logs: If the Crayons library provides release notes or change logs, carefully go through them to identify when the <fw-platform-table> component was added, modified, or deprecated.

  3. Test with different versions: Alternatively, you can test the code with different versions of the library and see if you can find one that supports the platform table. Keep in mind that you may need to modify the code for compatibility with different versions.

  4. Reach out to the community: It’s a good idea to ask for help on community forums such as Stack Overflow or the GitHub repository of Freshworks Crayons. The developers or community members might be able to provide the correct version information and guidance for using the platform table.

Regarding the package @freshworks/crayons-custom-objects, please ensure that you are following the correct usage and implementation guidelines as per the package’s documentation. If you are