Error creating Custom App on Developers Portal


I try to add a simple FreshService Custom App on the Developers portal but this fails with the message:


The app has been tested in develop mode and works.

Here some screenshots:

I get the error message when hitting the “Save and Publish” button.

I’ve already contacted support, but they couldn’t help me. Hope that someone can help this community.

Thanks in advance.

Hi @rmoreas ,

Hope you’re doing good.

Can you try the same by giving a simple overview (limiting your characters) in App Overview field once?

As you mentioned it works fine in develop mode, this would help us to confirm if there is some issue over there. Try this once & let us know.


1 Like

Hi @mariappan ,

I’ve already tried that too, gives the same error.

Hi @rmoreas ,

I’m able to publish a simple FreshService custom app without any issues.

  1. Can you confirm if your app is giving any errors in develop mode once again?
  2. If works fine, please share your manifest.json and fdk.log. If you can provide a minimal reproduction hiding sensitive details (if any) would also be helpful.



@rmoreas please share the HAR logs too. please clear the existing logs, click on save and publish and then send the HAR logs.

Thanks in advance

1 Like

Steps to generate and share the HAR log for this issue can be found in this handy wiki article.

1 Like


Yes I can confirm the app works in dev mode.

In attachment the manifest.json and fdk.log.

fdk.log (36.9 KB)
manifest.json.txt (386 Bytes)

Here some screenshots how the app looks like in dev mode



The HAR file contains sensitive information. I’d rather not share this in public.
Can I share this in person?

@rmoreas I have created a private message thread along with all the members in this thread. Please share the HAR log export in there and we can check. Thank you!

Hi @rmoreas

Thank you so much for helping us with the HAR logs so that it was easy for us to debug it faster.

As part of custom apps, App icon and screenshots is not mandatory. The issue is if the app icon is uploaded then it expects screenshots also. For time being, I can help you with a workaround meanwhile we will be fixing it soon from our end.

Workaround 1 :
You can remove the app icon and submit the app.

Workaround 2 :
(If you think you need app icon) You can add App icon and one or more screenshots (less than 5) with valid dimensions and submit the app

Sorry for causing any inconvenience. Please feel free to reach out in case of further queries.

Thanks and Regards,
Mughela Chandresh


Hi @Mughela_Chandresh ,

Thanks a lot! Just leaving out the app icon did the job!

I added an icon every time, not thinking that it caused the issue (I used it before for another app). Stupid that it took such a long time to come to this simple solution :slight_smile:


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.