Error in initializing fdk in Windows OS

Hi people, I am developing a custom serveless app and I am getting an error when I try to launch the command “fdk pack” or “fdk version” in cmd.

I will explain the step by step that I did to get the error. After running the command “fdk pack” the fdk asked to be updated I accepted the update and after that my CMD crashed during the update and I closed it, after closing the cmd I opened it again and got the following error after trying to run any of the above commands:

I have already tried to uninstall CLI and Node and install them again, but the error persists.

What can I do to solve this error?

Hi @Lucas_de_Lagos_Pando

Can you please try checking this post which seems related to your query? Please feel free to reach out if this doesn’t resolve your issue.

1 Like

Hi @Anand_Chandran

I tried to follow the steps in the post, but it didn’t work and the error continue

Hey @Lucas_de_Lagos_Pando ,

Can you please let us know what was your locally installed FDK version and for which version you got the update?

Hi @Aravind_Dasarathy

I had already updated the FDK to version 8.1.0, when I went to perform the fdk pack the above situation occurred

Hey @Lucas_de_Lagos_Pando ,

Can you please try using Node 14 and try installing fdk using ‘npm’? Please make sure that the npm version that you are using is compatible with that of the running node’s version.

npm install -g


1 Like

Hello @Aravind_Dasarathy,

I tried this process and fdk is still not working.

@Lucas_de_Lagos_Pando Since we couldn’t reproduce it at our end, can we do a call to troubleshoot it in your machine?

Will that work for you? If so, could you schedule a time in our Office hours calendar?

1 Like

Hello @Raviraj

Okay let’s make the call, I’ve already made an appointment through the link you sent.


Update from Office Hours:

I tried debugging the installation. We tried removing ~/.fdk/, uninstalling FDK, and reinstalling again. The installation went through but looks like something is wrong with the OS and/or the Node.js installation. They have already reinstalled Node.js twice. On this reinstall, FDK stopped producing any messages at all. Looks very much like Node.js sysout is broken.

After trying pretty much everything, we decided reinstalling the OS might be a good idea, because something is broken, and it is very unlikely to be an issue with FDK.

OS: Windows
Terminal: cmd.exe
Node.js major version: v14


This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.