[ERROR] Invalid type 'domain' found in iparams.json. [ERROR] Invalid keys in iparams.json

Hi, I’m trying to test an app but I get the following error regarding my iparams.json file. The app works fine if the domain and API key are hardcoded. Can you please help?

iparams.json file:

manifest.json file:

If I set the type as “text” for both the domain and the api_key, then I get the following error:

Can you please share with us the FDK version which you installed?
and as per your Manifest, your FDK doesn’t have the latest version
please update to the latest version.


1 Like

Hi @Santhosh ,

Thank you for your reply. I’ve tried to install the latest version but every time only the same version 6.0.1 gets installed as seen below.

I think you need to install the latest version by below one :point_down:

npm install https://dl.freshdev.io/cli/fdk.tgz -g


Thank you. I tried it but it still shows the same FDK version.

I’ve tried uninstalling FDK and also using npm cache clear --force but it always installs the same FDK version

Good Day!
Can you please let me know what is the node version you are using?
and if you are using below node 14, please try to upgrade the node version to 14 and try installing the FDK


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.