Error when install custom app : missed adding renderData()


I met an issue when installing the custom app (let’s call it version 2.0). The app is packed successfully, it works fine on local. If I install some apps successfully before (version 1.0), then update the new version with the new app (version 2.0), it works well.

The issue only happens when I tried to install directly the new app (version 2.0), it throws the error:

There was an error during installation. Please try again. If the error persists, please contact support.

This is my recent effort trying to install the app:

Thank you very much
Nhat Nguyen

Hi Nhat,

Hope you are doing good. :slight_smile:

Does this issue still persist ? Even i was facing this issue few days back but the next day after deploying as a new app worked for me.

If the issue still persist please try deploying as a new app. Can you also please confirm whether you are using any regex within the app and is it a serverless app?



This issue persists. The problem for me is on the contrary with you, it only happens when I deploy as a new app. When I update the App, it works fine and I can update successfully.

It is an app including a serverless app. I have changed to platform 2.2 as well. This problem occurs before the platform changing, and after changing, it continues to happen.

Btw, what kind of regex that you mentioned? I’m not very sure about this.

Thank you,


I would like to ask if there are any updates about this issue? This problem is really critical, if it persists, customers cannot install the app. Only those who have the old version of the app can update, while those who didn’t install it before cannot install the app.

Thank you

Hey @Nhat_Nguyen,

We are checking this, will keep you posted on this. also, could we please continue this conversation privately in basecamp as this is an account-specific issue.

Stay Safe :slight_smile:

@Nhat_Nguyen Can you please share the appId and appName which would be helpful for us to search through the logs?

The appName: GD - Platform 2.2
The appId: 44404-gd_-_platform_22

Thank you. Will check and get back to you

@Nhat_Nguyen there seems to be an issue with the app install callback. kindly use renderData() function with empty arguments in appropriate location inside app install callback for successful app installation.

for example :

onAppInstallCallback: function(payload) {
        console.log("Logging arguments from onAppInstallevent: " + JSON.stringify(payload));
        // If the setup is successful

let me know if you still face any issues.


Yes, this is the problem.
Thank you very much.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.