Facing 504 http Error while using Request APIs


We are calling our third-party API from Freshdesk using Request API. We are using staticIP parameter as true in options. We have our AWS instance in us-west-2. So, we whitelisted “ and” in AWS as in the image.
But we are facing the same issue as in the image.

FDK 504

Hi @Dineshkumar_Ravichan,

Could you post the code snippet of how the Request API is used? Please remove any business logic and any sensitive information in the code.

  1. Where is this Request API used in the app, Frontend, or serverless component?
  2. Does your AWS service receive the request after adding the static IP option and whitelisting the IPs?

Hi @Raviraj,


This Request API is used in CTI application to make call to Node Application Endpoint (endpoint_url is Node Application URL which is running in AWS EC2 instance (US WEST-2) and /getMappedNumber is a API available there). I followed your CTI implementation from Github.
Our AWS serer doesn’t receive any request after adding static IP option and whiltlisting the IPs.

There’s no issues, I could find with the code snippet.

Could you answer the following questions?

  1. Which region your Freshdesk account in? If you do not know, please let me know the account domain.
  2. You are changing the security group for the AWS EC2 instance in the screenshot. Could you let us know if there’s any other layer (ELB, Gateway) on top of that which has this blocked. Or any network ACL on top of your VPC.
    To find this out, you can approach AWS documentation and support for help.

I can initiate a private message to share the account domain.


We are using ELB layer and port 80, port 443 are in open by default.

Hi Dinesh,

We do not have any issues at our end for your account or Request API, in general.

We are not sure about the other configurations on your EC2 or ELB layer. Could you please approach AWS support to check on your IP whitelisting?
The listed IPs are the sources for the APIs. If they are properly whitelisted, the requests will reach your server.