! FDK exits with error after upgrading to 8.3.3!

Before upgrading to 8.3.3 fdk was working fine. Then I upgraded after being prompted and fdk update and now I get below error.

here is where I upgrading to 8.3.3:

fsales> fdk validate
? Version 8.3.3 is available for update, would you like to install it now? (Y/n) Yes
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'fdk@8.3.3',
npm WARN EBADENGINE   required: { node: '14', npm: '6' },
npm WARN EBADENGINE   current: { node: 'v14.19.1', npm: '8.12.1' }

removed 751 packages, changed 1 package, and audited 2 packages in 6s

found 0 vulnerabilities
Succesfully updated the CLI to version 8.3.3!

Please start the CLI again!
TrainingSvc> cd ../fsales

And here is the very next time I tried to run fdk:

fsales> fdk run
  throw err;

Error: Cannot find module 'winston'
Require stack:
- /Users/stevemc/.nvm/versions/node/v14.19.1/lib/node_modules/fdk/lib/logger.js
- /Users/stevemc/.nvm/versions/node/v14.19.1/lib/node_modules/fdk/index.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:902:15)
    at Function.Module._load (internal/modules/cjs/loader.js:746:27)
    at Module.require (internal/modules/cjs/loader.js:974:19)
    at require (internal/modules/cjs/helpers.js:101:18)
    at Object.<anonymous> (/Users/stevemc/.nvm/versions/node/v14.19.1/lib/node_modules/fdk/lib/logger.js:18:5)
    at Module._compile (internal/modules/cjs/loader.js:1085:14)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.Module._load (internal/modules/cjs/loader.js:790:12)
    at Module.require (internal/modules/cjs/loader.js:974:19) {
  requireStack: [

no mater what fdk command I run, I get same error. I appear to be 100% blocked.

I just updated the CLI.

The only thing that is different to you was the following:


Otherwise, I was able to successfully update and use the CLI. We do not recommend to use the npm version that is not shipped along with the node. See the reference.


Could you may be switch to the right npm version and try again? Let me know if you face any issues?


Thanks! That got me working again. After downgrading npm, I also had to re-install FDK. Now its working again.

Note: reason I updated was that after installing or upgrading FDK, npm shows this message encouraging users to upgrade: