"fdk run" to return 'undefined' after what seems like a timeout with googleapis

I’m stuck on an issue with ‘fdk run’. Its been a while since I compiled (fdk run) the app and now when I try to make changes and compile (fdk run) it, I get a long delay when I run ‘fdk run’ and then only ‘undefined’ is returned to the console. The fdk.log shows more but not giving any clues.

When I run ‘fdl validate’ and everything reported as ok.

Below is fdk log.

2022-02-20 21:07:30.578 -0800 [info] Starting local testing server at http://*:10001/    
Append 'dev=true' to your Freshworks_crm account URL to start testing    
e.g. https://domain.myfreshworks.com/crm/sales/contacts/2007663673?dev=true    
Quit the server with Control-C.
2022-02-20 21:07:30.578 -0800 [info] 
To simulate product, app setup, and external events, visit - http://localhost:10001/web/test
2022-02-20 21:07:30.578 -0800 [info] Populating test data with events found in the app
2022-02-20 21:07:30.579 -0800 [info] To test the installation page, visit - http://localhost:10001/custom_configs
2022-02-20 21:07:59.973 -0800 [debug] (e[34mdata-util.jse[0m) e[31mRead {"auditl_101_101_freshworks_crm":{"auditl_101_101_custom_iparams":{"log_level":"Verbose","log_payload":true}}}e[0m
2022-02-20 21:07:59.973 -0800 [debug] (e[34mbeevents.jse[0m) e[31mUsing {"log_level":"Verbose","log_payload":true} as iparams for testing.e[0m
2022-02-20 21:07:59.973 -0800 [debug] (e[34mbeevents.jse[0m) e[31mCalling event handler with <JSON DATA HERE>e[0m
2022-02-20 21:07:59.974 -0800 [debug] (e[34mcoverage-util.jse[0m) e[31mInstrumenting /Users/stevemc/Library/CloudStorage/OneDrive-Personal/SAFR/CRM/dev/apps/auditlog/server/server.jse[0m
2022-02-20 21:08:25.312 -0800 [error] undefined
2022-02-20 21:08:25.316 -0800 [debug] (e[34mcoverage-util.jse[0m) e[31mWriting coverage.e[0m
2022-02-20 21:13:24.700 -0800 [info] 
NOTE: We recommend a coverage of 80% for apps that are to be published in the public marketplace.

When I run ‘fdk run’ following output suggests that the dependency in manifest.json was updated:

manifest.json has this dependency:

“dependencies”: {
“googleapis”: “39.2.0”

Installing dependencies…> .

+ googleapis@39.2.0
updated 1 package and audited 76 packages in 2.351s

If I am not wrong, every time you invoke the webhook, you simply see undefined on the console?

I can see googleapis is 102MB size package on npm. But there could be more to the problem. Would it be possible to share the the app with which I can maybe reproduce the error?

The issue turned out to be due to OneDrive. A new version of OneDrive resulted in longer than normal delay in retrieving file when using Files on Demand feature. This was preventing the SDK from correctly working.

I solve the problem by choosing “Always store on device” for any of the Freshworks apps I’m working on.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.