FDK update is not working

Occasionally FDK tells me that an update is available and do I want to install it. I say yes and the npm process runs successfully telling it has updated the CLI to the new version.

Then at some point it will ask me again. The current version it keeps doing this with is 7.4.0.

Interestingly when I pack the app it says it is packed with Node v12.22.0 and FDK 7.1.0.

Any ideas?

There are 2 different things happening here:

  1. FDK update: FDK shows update prompts for updates to minor versions. E.g., 7.1.x7.2.x
  2. The engines fields in manifest.json are not updated for minor version changes when you run an updated FDK. This is because both Node.js and FDK avoid introducing breaking changes in minor versions.

For the first case, do you see any errors during the update process? We have released a few minor versions back to back over the last few months. If for some reason your updater fails, please reinstall FDK.

Hi Kaustav,

Thanks for the explanation. That is really useful.

I don’t see any error and the process finishes with a success message. I have tried manually updating the manifest.json field but this did not make any difference.

I just tried to run fdk version and it prompts me to upgrade to 7.4.0. It completed this successfully so I ran fdk version again. This time it gave me the the following message:

Installed: 7.1.0
Latest: 7.4.0
To install the latest version type ‘npm install https://dl.freshdev.io/cli/fdk-7.4.0.tgz -g’

I had not seen that before but ran this npm cli command successfully, then ran fdk version again but it presented me with the following again

Installed: 7.1.0
Latest: 7.4.0
To install the latest version type ‘npm install https://dl.freshdev.io/cli/fdk-7.4.0.tgz -g’

This could be a one of those situations where manually updating to FDK 7.4 will help. Please follow the CLI update instructions.

7.4 ships with a new internal feature to make sure we can prompt developers about updates (major or minor) more consistently.

Hi Kaustav,

I am afraid trying the CLI method isn’t working either.

Understood. Can you share any logs that you see? For example, outputs from the npm install command and any relevant fdk.log file.

Somebody from @Developer-Platform please help here.

Hi Rob,

If none of the above-mentioned steps work, can you clear the .fdk folder present in your root directory and try executing commands with the NODE_DEBUG=fdk environment variable? For example, in your app directory, try NODE_DEBUG=fdk fdk run. If prompted with an update, please update the fdk in this flow.

Once all is done, can you please share with us the logs for the mentioned steps? This will enable debug logs which might assist us more with troubleshooting.

1 Like

Since the release of FDK 7.5.1 the update is working again. :smiley:


Thanks, @RobAtOpinyin for confirming that the FDK v7.5.1 fixed the issue for you.

We have added only additional validations for the manifest.json file in the recent patch version update. Maybe the attempt to update FDK again has fixed any of the state updates that were missed in the previous update for you, I guess.

We will remember this pattern to fix it if it repeats for any other developers. Please share the debug log if it repeats for you.

:+1: Thanks to everyone for looking at this in the first place.

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.