Getting 403 while updating a Service request Item

Hi Team,

I am an admin in my instance and when I use the Service Desk API for Developers | Freshservice API to update a Service-Request, we get 403 response.

I tried the same in another instance and it worked!

Could you please help us out here?


Have you added the domain to whitelisted-domains in manifest.json?

Hi @Anand_Chandran,

Yes, we did!

Even we get this error even when we try this using postman or HTTP.

Hi @Anand_Chandran,

Is there any update on this?

Please let us know.

Hi @Bene_Immanuel

Could you please share the console error logs or screenshots if possible? Also, I would want you to refer to this thread to ensure that the correct credentials and methods are used.

Hi @Anand_Chandran,

Please refer to the attachment below. (644.7 KB)

Hi @Anand_Chandran,

Was this useful?

I hope you could get the request-id to debug this further.

Please let us know if any.

@Vinoth_Christofer can you please help here? Thanks!

Hi @Bene_Immanuel.

When a service request is in approved / approval requested state, the requested items update is restricted. And that is why 403 is returned for that specific service request.

Hope this helps.

1 Like