Iparams json not working in version 2.3 (In local env)

Hi Team,

I created a front-end freshdesk app with version 2.3. I configured iparams.json file with domain and apikey attributes. But when i run my app and open iparams page in local env, it is not loading the place holders for domain and api key instead it is completely empty page. I have attached the screenshot for your reference.

Please find my manifest.json below

  "platform-version": "2.3",
  "product": {
    "freshdesk": {
      "location": {
        "ticket_sidebar": {
          "url": "index.html",
          "icon": "styles/images/icon.svg"
      "requests": {}
  "engines": {
    "node": "18.14.2",
    "fdk": "9.0.0"

iparams.json file

    "domainName": {
        "display_name": "Domain Name",
        "description": "Please enter your domain name",
        "type": "domain",
        "type_attributes": {
            "product": "freshdesk"
        "required": true
    "apiKey": {
        "display_name": "API Key",
        "description": "Please enter your api_key",
        "type": "api_key",
        "secure": true,
        "required": true,
        "type_attributes": {
            "product": "freshdesk"

But when I create a custom iparams page with iparams.html and iparams.js file, I am able to see the iparams placeholder from the iparams.html in the local env.

The iparams.json is working when the app is deployed in test instance but not working in the local env.

Hey @Anantha_Narayanan,

The error is when you switch to a custom iparams page right? Updating the client JS resource in iparams.html should resolve it.

<script src="{{{appclient}}}"></script>

Do check out - Request Method which talks about this for front-end apps.

Hey @zach_jones_noel,

Thanks for the quick response. I am using <script src="{{{appclient}}}"></script> in iparams.html. The issue here is if I use iparams.json I am getting the freshapps error from the screenshot.

You cannot use both iparams.html and iparams.json in the same app.

iparams.html would have to use getConfigs() and postConfigs() to retrieve and post the iparam values.

Yeah, I agree with you. I am only using iparams.json as i have only 2 configuration. But it is not working as expected. So I tried using iparams.html and found that it is working as expected but not iparams.json.

Interesting, thanks for getting our attention on this.

Can you share your complete app zip file?

Sure, please find the zip below.
iparams.zip (5.2 KB)

The issue got resolved by itself after few days. NO codes were made.

Hey everyone!

This problem can often be caused if the fdk is not installed correctly. to fix the error it is enough to just uninstall and install the fdk.


This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.