Issue: {require_login=true} as a response to the API request

Unable to call the API with the API key

I am trying to call a GET request with the following command
curl -u “apikey:iCs6hBU69mFm07s9nKaT” -H “Content-Type: application/json” -v -i GET

I am getting below in the response

{“require_login”:true}* Connection #1 to host left intact

Our go-live date is approaching. This needs to be resolved as early as possible

Hi @kalyanikoul,
Welcome to the community,
As per your curl request, you need to replace your domain name and API key of your freshservice account
which I had highlighted in the below code snippet

curl -u “apikey:iCs6hBU69mFm07s9nKaT” -H “Content-Type: application/json” -v -i GET

you can find the domain name in your freshservice URL i.e -> xyz is your domain name
and you can find the API key in your profile settings

I hope it helps



This topic was automatically closed after 14 days. New replies are no longer allowed.