Need help with Allowlist NAT IPs

Hello, This message is on the top of my Freshdesk and I dont know how to do this from my end. We work from home and we dont have an IT that can help me with it

Hi @Ava_Amurao,

You can take a look at the Freshdesk solution article - Allowlist NAT IPs.

Reach out at if you have any questions.

Hi @zach_jones_noel ,
I also have the doubt Regarding the NAT IPs.

Is it mandatory to add Allowlist NAT IPs in our helpdesk?
And If yes, then from where we can add them?

In Admin > Helpdesk settings, There is a setting called Helpdesk restrictions,
So, is allowlist NAT IPs referring to that setting?
or it is located somewhere else in the Helpdesk?


Hello, I tried reaching out to them but they said that they can’t help me with this

Hi @Ava_Amurao and @Harsh_Suchak,

Do you have any external calls from your Freshdesk?
Such as requests made through webhooks and integrations?

If not, then you don’t need to do anything.

We make and received calls from Freshdesk. Do I still need to do this?

Hi @Ava_Amurao,

No you shouldn’t need to

Yes, We make API requests from integrations in which as per Freshdesk App SDK Docs we have used Request library to make API calls.

For those APIs used in the integrations, we have added in the “whitelisted-domains” in manifest.json file as per the docs.

Do we still need to do anything more?
When this notification from the above will disappear?