Npm Freshdesk SDK installation fails - v1

I’m trying to install the Freshdesk SDK following the guide at Quick Start.
The npm install command fails everytime.

Even though I run it using sudo I get permission denied Error.

@rockstar-developer - The link you are referring to is very old. It’s on us to make it undiscoverable. The installation steps mentioned in that document are no for the latest version of the platform. Apologies.

Please refer to this link - Quick Start of Platform V2 !

To avoid any inconsistencies, I’d recommend you to delete node and whatever you’ve tried to install completely and start over again.


Thank you for your quick response Saif and for your help!

I just wasted half a day with this exact same problem. Would be good if the old documentation pages could be marked as deprecated and link through to the latest quick start guide


@Dan_Parker @rockstar-developer - This issue has been addressed. Thank you for sharing your thoughts on this thread. In future, developers would not land on deprecated developer documentation.

1 Like