OAuth 2.0 Redirect URL Issue on Local and works fine on Production


We are trying to test docuSign Authentication from freshservice OAuth2.0 locally and facing an issue with redirect URL which is not as expected

Result : http://localhost:10001/auth/callback?callback=http://localhost:10001/custom_configs?product=freshservice&product=freshservice

Expected : http://localhost:10001/auth/callback

But works fine on production

So is there any way i can test the app locally

"client_id": "*****************************",
"client_secret": "*******************************",
"authorize_url": "https://account-d.docusign.com/oauth/auth",
"token_url": "https://account-d.docusign.com/oauth/code",
"options": {
    "scope": "signature"
"token_type": "account"


Hey, @Hassan_Tasleem1!
For test purpose, try to add to oauth_config.json the redirect_url:

	"options": {
		"scope": "signature",
		"redirect_url": [


Could you try whitelisting the ‘Result’ URL ?

Apparently it has worked with one of our community members,

Please let me know if that worked for you?

1 Like

Hi, @samuelpares,

I’ve already tried this but it didn’t work

Hi @Saif,

I tried to request after whitelisting the domain but now after OAuth login it takes me to http://localhost:10001/auth/index?callback=http://localhost:10001/custom_configs?product=freshservice this URL which cause an error of The Page isn't working

Isn’t the URL supposed to be having callback instead of index ?

As in,

1 Like