Old fdk version have no iparams page

Hi gang.

Did downgrade my node version to match a manifest.json in an older project.

“engines”: {
“node”: “14.20.0”,
“fdk”: “8.6.1”
}

Have confirmed that I am using node version 14.20.0 using the nvm package.
Have also installed the correct fdk version with the command:

npm install https://dl.freshdev.io/cli/fdk-8.6.1.tgz -g

After confirmig the version

fdk -v

I start the app. However the iparams page is not displaying any result. See below image.

Have tried in different browsers, with the same result. This iparams page is built from the iparams.json as per default.

Intrestringly, we have another custom app for a client where the manifest looks this:

“engines”: {
“node”: “14.0.0”,
“fdk”: “8.6.5”
}

When downgrading to the right version this iparams page is working as expected. This is built using the custom installation page with both iparams.html and iparams.js.

Is this an exected error? And are we required to rebuild older iparams.json files to use the custom installation page instead for older apps?