TypeError: Cannot read property ‘location’ of undefined

Hi Team,
While running a new freshsales custom app using the “your_first_app” template without change anything in the code. Am getting this error: “TypeError: Cannot read property ‘location’ of undefined”. Pls anyone help me how to solve this issue. Its urgent!
FDK version: 8.0.1
Node: v14.17.3


fdk.log (181.6 KB)

Hey @Keerthi_joe

I’ve tried creating a new app using the node and fdk version specified by you. It’s working without any error on my local machine. Can you please ensure that you have made any changes to the app code?

1 Like

@Keerthi_joe
Good Day!
As mentioned by @Anand_Chandran, kindly take a look at the manifest has correct location which is mentioned in the document,
and if it is correct, try deleting the .fdk folder in your home folder location and try run the application again.
hope it helps :slight_smile:

Thanks

1 Like

@Santhosh I run the app with no changes with react. I’ve deleted the .fdk folder as well

@mthomas-github
Quick Question
Are you using the react template app from the fdk?

Thanks

Yes I’m using the react template.

Hello

Is the issue still reproduceable? I am happy to assist if this persists still. Waiting for a confirmation