Unable to install Custom App - Validation failed


I recently started working on a serverless App to test some functions. In my first step I just used “fdk create”, selected Freshservice and Serverless. Then I added the “Domain” and “API key” to the iparams.json since I will need them later. Here is the iparams.json:

    "domainName": {
        "display_name": "Domain Name",
        "description": "Please enter your domain name",
        "type": "domain",
        "type_attributes": {
            "product": "freshservice"
        "required": true
    "apiKey": {
        "display_name": "API Key",
        "description": "Please enter your api_key",
        "type": "api_key",
        "secure": true,
        "required": true,
        "type_attributes": {
            "product": "freshservice"

When I tested the config page locally I had no problems, but after I uploaded the packed App file to our test account and tried to install the App, I get a “Validation failed” error:

I didn’t change anything else from the basic serverless template, and as far as I could see there is no additional validation of the iparams in the code. As you can see in the screenshot the Domain does match with the URL of our Account, and I copied the API key from the Account Admin user I am currently logged in as. Did I overlook something here?

Upon further analysis I found when I click install a Request is triggered that is supposed to validate the domain and API key. When I checked the Network logs in my browser, I found that this Request is failing with a 404 error “Request template not found”.


According to @Freddy this should be a temporary issue with the platform. Did you try after some time? Does it still show the same error? Your manifest.json has no issues.


Hello chrism,

As harishk mentioned, the issue with the “Validation failed” error should be temporary and related to the platform. You can try to install the app again after waiting for some time. If the issue persists, please contact Freshservice support for further assistance. Keep in mind that your manifest.json file doesn’t have any issues, as shown in harishk’s screenshot.

Thanks for your suggestion. I did some further testing, and it seems the problem was that my App did not contain a requests.json file.
Originally I used the fdk create command to get an App template and then I just added two iparams for domain and api_key. Since the error was mentioning a missing request template I tried adding an requests.json file with with no request templates
and with this I can install my App now.
Since this is not documented anywhere and the template provided by Freshworks also doesn’t inlcude a requests.jon file I didn’t think this could be the problem.

Does anyone have an explanation why I need a requests.json file even if I don’t use any Request templates?

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.