Unable to test apps locally

We’re unable to test the app locally in Chrome by running the FDK server with the command, fdk run . The app icon is not visible. Shield icon does not appear in the browser address bar to allow the insecure content to load the app running on the FDK server on HTTP.

Chrome version: 79.0.3945.117
FDK version: 6.0.0


​If you are testing a frontend app, because of a recent update to Chrome, you would have to follow the following steps in order to test frontend apps for chrome:

​We recommend using only the Chrome browser for local testing.

Version not affected: 79.0.3945.88
Version affected: 79.0.3945.117 and greater

Steps to add permanently in the Chrome browser:

  1. Open Freshdesk or other Freshworks product URL (Eg.: sample.freshdesk.com, sample.freshservice.com, sample.freshsales.io, etc.)
  2. Click on the lock icon in the address bar in the front.
  3. Click on Site settings option with a gear icon. It will redirect to Chrome’s settings for this particular site.
  4. In the permissions listed, for Insecure content permission, mark it as Allow for this site. This is equivalent to usually giving permission to load the unsafe scripts from the shield icon that would appear in the browser address bar.
  5. Now, refresh the page and the apps will be loaded in the configured Freshworks product. It has to be done for each product if you’re using multiple Freshworks products. As a plus, it won’t require this permission every time the app is run.

Note: If the browser settings get reset or this permission for the Freshworks products gets removed, the same steps have to be followed to add it again to test the apps locally.