Unable to test sample app when appending ?dev=true

Hi there, I’ve been scouring the forums and all of the articles online however I cannot seem to find our answer anywhere. Currently, I’m just trying to get the your_first_app to load onto our page, but I can’t seem to get it to work.

FDK works fine, I have installed, no errors. I then created the your_first_app from the template in the FDK, and then started the local server by using fdk run. I get no errors from the console.

I then proceed to our Freshdesk portal, login, view a ticket, and on the padlock I allow all insecure scripts. However, upon the refresh, there is no sign of the test app!

I’ve been following both this: Introduction to Freshworks Developer Platform and this: Quick Start

Our Firewall on that particular stack allows all outgoing traffic, so it shouldn’t be blocking anything.

Thanks in advance,

Hi @Sam_Hawes,

Could you attach your the fdk version, browser and it’s version, and screenshot of the location where the app expected to load? It might help narrow down the issue or try out a different scenario if possible.

Hi @Raviraj,

I’ve solved this issue now after realising my stupidity - I was launching the Node.JS server and app on a separate machine to the browser I was using.

Thanks for your help regardless!


Oh. Thanks for the confirmation that it works now.
You’re welcome! :slight_smile:

1 Like