PLATFORM error on custom app when running on server, but no error in local dev environment

working on a custom app using FDK 9.0.5, Node v18.18.2.

Used sample app at request-method-samples/product-samples/freshservice at main · freshworks-developers/request-method-samples ( and modified as needed and received error, also tried code exactly as presented with same error. In both cases there are no issues when using local development environment.


var client;

(async function init() {
  client = await app.initialized();'app.activated', renderStarWarsInfo);

//To demonstrate a simple GET request
async function getStarWarsChar() {
  const starwarsCharsElement = document.querySelector('#starWarsCharsCount');
  try {
    let starwarsChars = await client.request.invokeTemplate(
    let starwarsCharsJSON = JSON.parse(starwarsChars.response);
    starwarsCharsElement.innerHTML = starwarsCharsJSON.count;
  } catch (err) {
    starwarsCharsElement.innerHTML = `-` + err;

async function renderStarWarsInfo() {
  await getStarWarsChar();


  "platform-version": "2.3",
  "product": {
    "freshservice": {
      "location": {
        "asset_sidebar": {
          "url": "index.html",
          "icon": "styles/images/icon.svg"
      "requests": {
        "getStarWarsPeople": {}
  "engines": {
    "node": "18.18.2",
    "fdk": "9.0.5"


  "getStarWarsPeople": {
    "schema": {
      "method": "GET",
      "host": "",
      "path": "/api/people"


    <link rel="stylesheet" type="text/css" href="./styles/style.css" />
    <script src="{{{appclient}}}"></script>

    <div class="fw-card-2 fw-p-12 fw-flex fw-flex-row">
      <section class="fw-flex-grow">
        <h3 class="fw-type-h5 fw-my-0">Star Wars characters</h3>
        <p class="fw-type-xs fw-my-0" id="starWarsCharsCount"></p>
  <script defer src="./scripts/app.js"></script>

1 Like

I tried the same app and it seems to be working.
Can you please share the appID and region, so that we can check the logs from our end.

1 Like

We are hitting the same problem too. It works in local dev and not as a custom app.

The AppId is 85712. I’m not sure where to find the region, but we are located in the US.

HI @Dustin_Scott , @shalabi

Could you verify whether the app has been published or if it’s currently in a testing phase? If it’s still in a test state, please utilize the “save and publish” functionality to transition it into a fully published app, and then retest the scenario accordingly.


cc @Logesh_Narayanan

Thanks Nadeem,
Publishing the app resolved the problem. Is this always going to be the solution, or will we be able to test apps once installed prior to giving access to all users?


We would like to inform you that we have already rolled out the fix on last Friday .


hi ,
i developed a app and the app makes calls to the freshdesk api’s provided the subdomain and apikey, the app makes successful api’s calls to freshdesk api’s while developing, but when i pushed my app to marketplace the api’s calls fail with status code 401 even after providing the apikey and subdomain.

“GetTicketDetails” : {
“schema”: {
“method”: “GET”,
“protocol”: “https”,
“host”: “<%= iparam.subdomain %>”,
“path”: “/api/v2/tickets/<%= context.ticketid %>”,
“headers”: {
“Authorization”: “Basic <%= encode(iparam.apikey) +‘:X’ %>”,
“Content-Type”: “application/json”

response of the api
“status”: 401,
“headers”: {
“date”: “Tue, 05 Dec 2023 09:57:02 GMT”,
“content-type”: “application/json; charset=utf-8”,
“transfer-encoding”: “chunked”,
“connection”: “close”,
“status”: “401 Unauthorized”,
“x-request-id”: “c4e6126d-463d-495c-b7ee-f12834e38b3d”,
“x-freshdesk-api-version”: “latest=v2; requested=v2”,
“content-security-policy”: “default-src ‘self’; connect-src ‘self’ * * * * * * * Sign In | Sentry wss:// wss:// wss:// data: blob: wss:// * *; font-src ‘self’ * data:; frame-src ‘self’ https:; img-src ‘self’ https: data: blob:; media-src ‘self’ https: blob:; object-src ‘none’; script-src ‘self’ * * * * * * * * * * ‘unsafe-inline’ ‘unsafe-eval’; style-src ‘self’ * * * * * * ‘unsafe-inline’; worker-src ‘self’ blob:”,
“cache-control”: “no-cache”,
“x-xss-protection”: “1; mode=block”,
“x-content-type-options”: “nosniff”,
“set-cookie”: [
“_x_w=7_1; path=/; HttpOnly; secure”,
“_x_m=x_c; path=/; HttpOnly; secure”
“x-fw-ratelimiting-managed”: “true”,
“x-ratelimit-total”: “50”,
“x-ratelimit-remaining”: “47”,
“x-ratelimit-used-currentrequest”: “2”,
“x-envoy-upstream-service-time”: “49”,
“x-trace-id”: “00-1183a86d7138870eb0f68b5a5455566a-9b41da2d23efb8b3-00”,
“nel”: “{ "report_to": "nel-endpoint-freshdesk", "max_age": 2592000, "include_subdomains": true}”,
“report-to”: "{ "group": "nel-endpoint-freshdesk", "max_age": 2592000, "include_subdomains": true, "endpoints": [{"url": "\“}]}”,
“server”: “fwe”
“response”: “{"code":"invalid_credentials","message":"You have to be logged in to perform this action."}”,
“errorSource”: “APP”,
“attempts”: 1

it doesn’t seems to be fixed in fdk version “9.0.5”, do i need to upgrade to “9.0.6” ??