Serverless Custom App isn't running

Hello everyone!

I’m developing a serverless custom app for freshsales suite that has a onCustomModuleCreate, the problem that I’m facing is, when I test the app on the plataform, the app doesn’t execute, when I look at the logs there is no entries.

So because of that I commented all of my logic in the code and only included the basic, like so:

Even with just that bit, the app still doesn’t execute, and no log appears, I believe that there isn’t anything wrong with the code I’m deploying.

One thing that I can think of that might be the cause of this is that, some days ago, I had a problem with the fdk and I had to reinstall node, nvm and the fdk itself, after that occurrence, this problem showed up. Maybe the fdk pack command isn’t working as expected after the reinstallations, but it can be just a coincidence :grimacing:.

So I need help to figure this thing out…


Good day!
Are you running the app locally or published as a custom app?
If you are running the app locally, you can’t get the logs.

Hope it helps :slight_smile:


Can you try to run fdk run command in debug mode

NODE_DEBUG=fdk fdk run

and share the logs of it? Also try to access the events page in localhost:10001

Hi there!

I forgot to mention that the custom app does executes locally, but when I deploy it to the plataform, it doesn’t run…

I also encountered a similar type of issue with my custom app… but later tried validating and packing multiple times and In my case I had some mistakes with the headers and the authentication in authorization. So if you are dealing with any request method do check the headers and if not sorry my friend :sweat_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.