FCRM product events and Request API not working


I am facing these issues in Freshworks CRM:

  1. Product events are not triggering. We are using onTaskUpdate and onTaskCreate and both of these are not working. This is verified that there are no issues in our code since this was working fine before.
  2. Requests are being time out. the same request from postman is working fine (response time: 3 sec), also since its an omni app, the same code works fine on FreshSales.

Is this an account specific issue or product related issue?

Hi @yusrakhatri,

One way, I will try to reproduce the issue and build a sample app to investigate further.

1 Like

Still facing this issue at our account. I can add you to it and you can check over there?

Hi @yusrakhatri,

I tried making simple request as follows

Please ignore async await used in this code snippet.Assume them to be .then() . That is for future releases of fdk. :) 
document.onreadystatechange = function () {
  if (document.readyState === 'interactive') renderApp();

  async function renderApp() {
    var _client = await app.initialized();
    window['client'] = _client;
    client.events.on('app.activated', onAppActivate);

async function onAppActivate() {
  var btn = document.querySelector('.btn-open');
  btn.addEventListener('click', openModal);
  let { response } = await client.request.get('https://httpbin.org/uuid');

I was able to get an response as expected. Can you please try again and confirm that part.

Coming to the product events part, I defined onTaskCreate , onTaskUpdate or even onContactCreate weren’t invoked when I was trying to reproduce the issue. I decided to give it an ~40 min time to see if they are invoked. I will keep you posted on top of it.

1 Like


On the day of your report, I found out that Product Events were delayed before respective handlers can be invoked. Today it appears to be stable and I am able to see logs from a sample app

Hopefully, it could be temporary problem and might have solved for you. Please let us know if problem persists.


Yes, it is working fine now. We have been facing this issue on and off though. Sometimes it works perfectly, sometimes it doesn’t.

1 Like